Remote - WSL拡張を使ったVSCodeで新規ファイルをcodeコマンドから開けない

この問題で無駄に時間を消費してしまったんですが、Remote - WSL拡張を使ったVSCodeで新規ファイルをcodeコマンドから開けない現象に遭遇しました。

2021/11/15 追記分

System Installerでなくとも、1.62.1(1つ前のバージョン)のUser Installerでも問題が発生しないことは確認できています。

github.com

アップデートされると問題が再発するので、自動アップデートがされないように設定を変更しておくことをオススメします。(あまり良くはないですが)

2021/11/14 に書いてた部分

結論としては原因不明だったのですが、元々VSCodeをUser Installerでインストールしていて1.62.2にアップグレードしたら発生した気がしていたので、 1.62.0のSystem Installerでインストールし直したら再発しなくなりました。

問題が起きていた環境

解決した環境